Printable version

Drivers & software

* RECOMMENDED * HP Lights-Out Configuration Utility

By downloading, you agree to the terms and conditions of the Hewlett Packard Enterprise Software License Agreement.
Note:  Some software requires a valid warranty, current Hewlett Packard Enterprise support contract, or a license fee.

Type: Software - Lights-Out Management
Version: 1.5.0(24 Oct 2016)
Operating System(s): Microsoft Windows Server 2008 W32
Microsoft Windows Server 2008 x64
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 Essentials
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Microsoft Windows 7 (64-bit)
Microsoft Windows Vista (32-bit)
Microsoft Windows Vista (64-bit)
Microsoft Windows 7 (32-bit)
Microsoft Windows 7 (32-bit)
Microsoft Windows 8 (64-bit)
Microsoft Windows 7 (64-bit)
Microsoft Windows 8 (32-bit)
Microsoft Windows 8 (64-bit)
Microsoft Windows 8.1 (32-bit)
Microsoft Windows 8.1 (64-bit)
Microsoft Windows 8.1 (32-bit)
Microsoft Windows 8.1 (64-bit)
File name: SP71387.msi (582 KB)
The Lights-Out Configuration Utility (HPQLOCFG.EXE) is a Windows®-based utility that connects to iLO 3 or iLO 4 using a secure connection over the network. RIBCL scripts are passed over the secure connection to HPQLOCFG. This utility requires a valid user ID and password with the appropriate privileges.

Prerequisites:

- HP Lights-Out Configuration Utility Tool requires

  • Microsoft .NET Framework 3.5 or above.
  • Microsoft .NET Framework 4.5 or above when FIPS Mode or Enforce AES/3DES Encryption is enabled in iLO 4.

- This utility requires the following minimum firmware revisions:

  • Integrated Lights-Out 4 firmware version 1.00 or later
  • Integrated Lights-Out 3 firmware version 1.00 or later

To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

dc40014eac040f17806495bce4d0f4207195c15ee1309996d815f56c03434ed0 SP71387.msi

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Uninstall any older version of HP Lights-Out Configuration Utility(HPQLOCFG) before installing this version of HPQLOCFG.

Create a directory on your hard-drive.

Copy this SoftPaq to the new directory.

From this new directory, run SoftPaq to extract the necessary files.

See the RIBCL scripting guidelines in the iLO User Guide.

 

 

Sample scripts may be downloaded from www.hp.com/go/ilo. Select your Lights-Out product, click on "Download software" link, select the operating system. Download "HP Lights-Out XML Scripting Sample for Windows" or "HP Lights-Out XML PERL Scripting Sample for Linux".

 


End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


Notes:
Documentation
Instructions for using this utility and RIBCL syntax for iLO can be found in the HP Integrated Lights-Out Management Processor Scripting and Command Line Resource Guide available at following the link at: http://www.compaq.com/products/servers/management/ilo/documentation.html

Sample XML scripts may be downloaded from www.hp.com/go/ilo. Select your Lights-Out product, click on "Download software" link, select the operating system. Download "HP Lights-Out XML Scripting Sample for Windows" or "HP Lights-Out XML PERL Scripting Sample for Linux".


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


  • This version of HPQLOCFG supports iLO 4 firmware version 2.30 onwards when FIPS Mode or Enforce AES/3DES Encryption mode is enabled.

Note: If AES/FIPS is enabled in iLO, you may need to upgrade to .NET Framework v4.5 or above to communicate with iLO. Also make sure the Operating System supports TLSv1.1 and TLSv1.2. For more information please see iLO 4 Scripting and Command Line Guide.

Version:1.5.0 (24 Oct 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


  • This version of HPQLOCFG supports iLO 4 firmware version 2.30 onwards when FIPS Mode or Enforce AES/3DES Encryption mode is enabled.

Note: If AES/FIPS is enabled in iLO, you may need to upgrade to .NET Framework v4.5 or above to communicate with iLO. Also make sure the Operating System supports TLSv1.1 and TLSv1.2. For more information please see iLO 4 Scripting and Command Line Guide.


Version:1.4.0 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • HPQLOCFG gracefully displays an error message and does not close with an exception when there are duplicate keys in the substitute variable string.

Version:1.3.0 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


- HPQLOCFG accepts empty(NULL) values for substitute variables when used with -t option.
- In the log file HPQLOCFG reported "Script Succeded" even when the execution of script failed.


Version:1.2.0 (9 Sep 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


 1) When running HPQLOCFG, occasionally there used to be an ERROR "Exception has been thrown by the target of an invocation". This issue is fixed in the current version.
 2) During firmware update, occasionally an error was thrown with message like 'Error:Line #5: syntax error near "RI"', though the firmware was updated succesfully. This issue is fixed in the current version.


Version:1.1.0 (18 Feb 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • RIBCL output occasionally displays an extra INFORM tag
Enhancements

  • Allow up to 50  substitute variables

Version:1.0.0 (23 Jul 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • DHCPV6 Enhancement and IPv6 support for iLO 4 FW v1.30 and iLO 3 FW v1.60


Subscribe to driver and support alerts

Sign up now for customized driver, security, patch, and support email alerts.
Type: Software - Lights-Out Management
Version: 1.5.0(24 Oct 2016)
Operating System(s):
Microsoft Windows Server 2008 W32
Microsoft Windows Server 2008 x64
Microsoft Windows Server 2008 R2
Microsoft Windows Server 2012
Microsoft Windows Server 2012 Essentials
Microsoft Windows Server 2012 R2
Microsoft Windows Server 2016
Microsoft Windows 7 (64-bit)
Microsoft Windows Vista (32-bit)
Microsoft Windows Vista (64-bit)
Microsoft Windows 7 (32-bit)
Microsoft Windows 7 (32-bit)
Microsoft Windows 8 (64-bit)
Microsoft Windows 7 (64-bit)
Microsoft Windows 8 (32-bit)
Microsoft Windows 8 (64-bit)
Microsoft Windows 8.1 (32-bit)
Microsoft Windows 8.1 (64-bit)
Microsoft Windows 8.1 (32-bit)
Microsoft Windows 8.1 (64-bit)

Description

The Lights-Out Configuration Utility (HPQLOCFG.EXE) is a Windows®-based utility that connects to iLO 3 or iLO 4 using a secure connection over the network. RIBCL scripts are passed over the secure connection to HPQLOCFG. This utility requires a valid user ID and password with the appropriate privileges.

Installation Instructions

Prerequisites:

- HP Lights-Out Configuration Utility Tool requires

  • Microsoft .NET Framework 3.5 or above.
  • Microsoft .NET Framework 4.5 or above when FIPS Mode or Enforce AES/3DES Encryption is enabled in iLO 4.

- This utility requires the following minimum firmware revisions:

  • Integrated Lights-Out 4 firmware version 1.00 or later
  • Integrated Lights-Out 3 firmware version 1.00 or later

To ensure the integrity of your download, HPE recommends verifying your results with this SHA-256 Checksum value:

dc40014eac040f17806495bce4d0f4207195c15ee1309996d815f56c03434ed0 SP71387.msi

Reboot Requirement:
Reboot is not required after installation for updates to take effect and hardware stability to be maintained.


Installation:

Uninstall any older version of HP Lights-Out Configuration Utility(HPQLOCFG) before installing this version of HPQLOCFG.

Create a directory on your hard-drive.

Copy this SoftPaq to the new directory.

From this new directory, run SoftPaq to extract the necessary files.

See the RIBCL scripting guidelines in the iLO User Guide.

 

 

Sample scripts may be downloaded from www.hp.com/go/ilo. Select your Lights-Out product, click on "Download software" link, select the operating system. Download "HP Lights-Out XML Scripting Sample for Windows" or "HP Lights-Out XML PERL Scripting Sample for Linux".

 


Release Notes

End User License Agreements:
HPE Software License Agreement v1


Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


Notes:
Documentation
Instructions for using this utility and RIBCL syntax for iLO can be found in the HP Integrated Lights-Out Management Processor Scripting and Command Line Resource Guide available at following the link at: http://www.compaq.com/products/servers/management/ilo/documentation.html

Sample XML scripts may be downloaded from www.hp.com/go/ilo. Select your Lights-Out product, click on "Download software" link, select the operating system. Download "HP Lights-Out XML Scripting Sample for Windows" or "HP Lights-Out XML PERL Scripting Sample for Linux".


Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


  • This version of HPQLOCFG supports iLO 4 firmware version 2.30 onwards when FIPS Mode or Enforce AES/3DES Encryption mode is enabled.

Note: If AES/FIPS is enabled in iLO, you may need to upgrade to .NET Framework v4.5 or above to communicate with iLO. Also make sure the Operating System supports TLSv1.1 and TLSv1.2. For more information please see iLO 4 Scripting and Command Line Guide.

Revision History

Version:1.5.0 (24 Oct 2016)
Fixes

Upgrade Requirement:
Recommended - HPE recommends users update to this version at their earliest convenience.

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

For iLO 4 Firmware versions below 2.30, iLO 2 and iLO 3, it is recommended to upgrade to HPQLOCFG v1.50.


  • This version of HPQLOCFG supports iLO 4 firmware version 2.30 onwards when FIPS Mode or Enforce AES/3DES Encryption mode is enabled.

Note: If AES/FIPS is enabled in iLO, you may need to upgrade to .NET Framework v4.5 or above to communicate with iLO. Also make sure the Operating System supports TLSv1.1 and TLSv1.2. For more information please see iLO 4 Scripting and Command Line Guide.


Version:1.4.0 (15 Jun 2015)
Fixes

Upgrade Requirement:
Optional - Users should update to this version if their system is affected by one of the documented fixes or if there is a desire to utilize any of the enhanced functionality provided by this version.


  • HPQLOCFG gracefully displays an error message and does not close with an exception when there are duplicate keys in the substitute variable string.

Version:1.3.0 (30 Mar 2015)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


- HPQLOCFG accepts empty(NULL) values for substitute variables when used with -t option.
- In the log file HPQLOCFG reported "Script Succeded" even when the execution of script failed.


Version:1.2.0 (9 Sep 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


 1) When running HPQLOCFG, occasionally there used to be an ERROR "Exception has been thrown by the target of an invocation". This issue is fixed in the current version.
 2) During firmware update, occasionally an error was thrown with message like 'Error:Line #5: syntax error near "RI"', though the firmware was updated succesfully. This issue is fixed in the current version.


Version:1.1.0 (18 Feb 2014)
Fixes

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • RIBCL output occasionally displays an extra INFORM tag
Enhancements

  • Allow up to 50  substitute variables

Version:1.0.0 (23 Jul 2013)
Enhancements

Upgrade Requirement:
Recommended - HP recommends users update to this version at their earliest convenience.


  • DHCPV6 Enhancement and IPv6 support for iLO 4 FW v1.30 and iLO 3 FW v1.60